Email Deliverability Issue
Incident Report for Better Impact
Update
We are continuing to work on a fix for this issue.
Posted Apr 08, 2024 - 15:39 EDT
Update
We are continuing to investigate root cause, and are working on putting measure in place to mitigate the issue.
Posted Apr 05, 2024 - 11:03 EDT
Identified
Unfortunately our mail service has been listed on a block-list and mail deliverability to a number of domains has been affected. The team is working hard to have our service removed from the list to ensure deliverability for everyone.

We will provide updates as we are able.
Posted Apr 04, 2024 - 01:30 EDT
This incident affects: Email Delivery.