Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 26, 2024 - 22:00 EDT
Scheduled
We will be performing server maintenance - during this period the myImpactPage.com and admin.betterimpact.com portals will be unavailable for approximately 15-20 minutes.
This maintenance will begin at the following local times:
New York, USA: Friday, July 26, 2024 10:00 PM London, UK: Saturday, 27 July 2024 3:00 AM Sydney, Australia: Saturday, 27 July 2024 12:00 PM
Posted Jul 23, 2024 - 12:00 EDT
This scheduled maintenance affected: Web Application.