Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2023 - 22:00 EST
Scheduled
We will be performing server maintenance - during this period the myImpactPage.com and admin.betterimpact.com portals will be unavailable for approximately 20-30 minutes.
This maintenance will begin at the following local times:
New York, USA: Friday, December 1, 2023 10:00 PM London, UK: Saturday, 2 December 2023 3:00 AM Sydney, Australia: Saturday, 2 December 2023 2:00 PM
Posted Nov 27, 2023 - 08:33 EST
This scheduled maintenance affected: Web Application.