Issues with our content delivery network provider
Incident Report for Better Impact
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 07:59 EDT
Monitoring
It appears that our services are widely accessible again. We will continue to monitor the situation to ensure our application remains reachable from all portions of the internet.
Posted Jun 08, 2021 - 07:08 EDT
Update
It appears that there is a major outage affecting large portions of the internet right now. Our services are up and running, but some of our members will not be able to reach them at the moment. Updates will be provided as we investigate further.
Posted Jun 08, 2021 - 06:44 EDT
Identified
Our CDN (Content Delivery Network) provider is currently experiencing issues that are causing some site pages not to load. We have taken steps to bypass them to restore service. The site is expected to become accessible again within the next 5 minutes.
Posted Jun 08, 2021 - 06:29 EDT
This incident affected: Web Application.