Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 22:00 EST
Scheduled
We will be performing server maintenance - during this period the myImpactPage.com and admin.betterimpact.com portals will be unavailable for approximately 15-20 minutes.
This maintenance will begin at the following local times:
New York, USA: Friday, November 15, 2024 10:00 PM London, UK: Saturday, 16 November 2024 3:00 AM Sydney, Australia: Saturday, 16 November 2024 2:00 PM
Posted Nov 12, 2024 - 11:38 EST
This scheduled maintenance affected: Web Application.