Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2024 - 22:00 EDT
Scheduled
We will be upgrading our software to the latest version - during this maintenance period the myImpactPage.com and admin.betterimpact.com portals will be unavailable for approximately 5-10 minutes.
This update will begin at the following local times:
New York, USA: Sunday, March 17, 2024 10:00 PM London, UK: Monday, 18 March 2024 2:00 AM Sydney, Australia: Monday, 18 March 2024 1:00 PM
Posted Mar 13, 2024 - 08:43 EDT
This scheduled maintenance affected: Web Application.